Home CCNA הסבר על ניתוב דינמי ופרוטוקול RIP

הסבר על ניתוב דינמי ופרוטוקול RIP

by Tal Ben Shushan 12/02/2017 0 comment
הסבר על ניתוב דינמי ופרוטוקול RIP

הסבר על ניתוב דינמי

ניתוב דינמי שונה מניתוב סטטי שכן הוא “מגלה” רשתות לבד מבלי הצורך להגיד לו בכל נקודה ברשת איפה נמצאת רשת כך וכך וזה חוסך הרבה ניהול מצדכם, ישנם גם חסרונות לניתוב דינמי

ניתוב דינמי מתבסס על החלפת “מידע” של ניתוב ברשת ה”מידע” הוא עדכונים בין הראוטרים על מנת לגלות איזה רשתות שוכנות ברשת, פרוטוקולי הניתוב משתמשים באלגוריתמים על מנת להעביר את המידע וזאת על מנת ליצור מצב בו לא רק הם יודעים אילו רשתות שוכנות איפה אלא גם לדעת מהיא הדרך המהירה ביותר, הקצרה ביותר, האמינה ביותר, הכי פחות עמוסה וכו’ כמובן שלא כל הפרוטוקולים משתמשים בכל הטכניקות אך הם דיי דומים אחד לשני.
הם עובדים ב4 שיטות, גילוי רשתות חדשות, תחזוק טבלת ניתוב הכי עדכנית שניתן, בחירת הדרך הטובה ביותר ליעד,יכולת למצוא דרך חדשה ליעד אם הדרך הישנה כבר לא עובדת.

RIP – קיצור של Routing Information Protocol הוא משתמש באלגוריתם של בלמן-פורד והוא אומר בקצרה, מה הדרך הקצרה ביותר על מנת להגיע לצומת (במקרה שלנו לרשת מסוימת)
הוא מפרסם כל 30 שניות את טבלת ה Route שלו לכל שכניו (ראוטרים אחרים שהוא מכיר) על מנת להודיע להם איזה רשתות הוא מכיר.
נוסף על כך, הוא משתמש בשיטת חישוב של, כמה קפיצות עד ליעד ומציג אותם כ Metric ואינו מחשב את מהירות החיבור שכן הוא יכול לעבור פחות קפיצות אך על קווים איטיים יותר ולכן אינו נחשב לפרוטוקול ניתוב מהיר ואפילו מיושן.

על מנת להגדיר פרוטוקול ניתוב כמו RIP עלינו להגדיר לכל ראוטר איזה רשתות הוא יפרסם לשאר הראוטרים בRIP, וזאת נעשה על ידי פקודת Netowork X.X.X.X כך נגיד לו את הרשת זו שנמצאת אצלך (מחוברת ישירות) תפרסם ב RIP לשכניך, לRIP יש 2 גירסאות, אחת ישנה RIPv1 ואחת יותר חדשה בשם RIPv2

חשוב לזכור שכל 30 שניות מפרסם RIP את הרשתות שלו

RIPv1 Classful

RIP בגרסתו הראשונה הוא למעשה פרוטוקול ניתוב דיי מיושן, כאשר אתם מפרסמים רשת מסוימת RIP מפרסם את הרשת לפי ה Classful זאת אומרת שהוא יבדוק את טבלת ה Classful ולפיה יחליט איזה רשת זו, לדוגמה

192.168.1.0 – רשת זו ששייכת ל Class C ולכן זה /24 או 255.255.255.0

172.16.1.0 – רשת זו ששייכת ל Class B ולכן זה /16 או 255.255.0.0

10.10.10.0 – זו רשת ששייכת ל Class A ולכן זה 255.0.0.0

חשוב להבין גם אם החלטתם שרשת 192.168.1.0 היא רשת /16 או Class B זה לא מעניין את RIPv1 הוא לא יודע את זה כיוון שאינו עובד בשיטת ה Classless

RIPv2 Classless

RIPv2 הוא למעשה Classless הוא הההפך מ Classful זה אומר שניתן להגדיר רשת שלא ב Class שלה ולהשתמש בה בניתוב לדוגמה

192.168.1.0/16 וRIP ידע לפרסם את הרשת הזו בדיוק.

Passive Interfaces

למעשה RIP מפרסם את הרשתות רק דרך פורטים אליהם מחוברים ראוטרים אחרים שמשתמשים ב RIP כפרוטוקול הניתוב שלהם, אבל מה קורה כאשר אתם רוצים שRIP לא יפרסם דרך פורט מסוים את הרשתות שלו?

למה לעשות את זה?

  1. אבטחת מידע, פרסום רשתות לראוטרים שאולי הם לא שייכים לארגון שלכם… או ראוטרים שלא מאובטחים כראוי…
  2. בזבוז משאבים ובזבוז רוחב פס

אז אך מבצעים Passive Interface?

R10>en

R10#conf t

R10(config)#router rip

 

R10(config-router)#passive-interface g0/0

כך למשל הגדרנו את פורט g0/0 בראוטר שלא יפרסם RIP דרכו, ניתן להגדיר שאף פורט בראוטר יפרסם את הרשתות ואז לבטל את החסימה על פורטים מסוימים

R10(config-router)#passive-interface default

 הDefault אומר שכל הפורטים חסומים ואז אפשר לבצע No כדי לבטל את החסימה על הפורטים שאנחנו כן רוצים שיפרסמו את הרשתות

R10(config-router)#no passive-interface g0/0

מעבדה

להורדת המעבדה

בואו נראה כיצד זה מבוצע.

 

 

לפנינו רשת עם 11 רשתות, בואו נגדיר רשת זו עם RIP,

נלך לRouter6 ששמו R6

R6>en

R6#conf t

R6(config)#router rip

כעת אנחנו מגדירים את פרוטוקול RIP

R6(config-router)#version 2

אנחנו מעוניינים ב RIPv2 שכן RIPv1 הוא Classful

R6(config-router)#network 192.168.1.0

R6(config-router)#network 172.16.30.0

נגדיר את 2 הרשתות שמחוברות ישירות ל R6 (ניתן לראות בתרשים למעלה)

עכשיו נעבור ל R1 על מנת להגדיר את הרשתות שהוא מכיר ומחוברות אליו

R1>en

R1#conf t

R1(config)#router rip

R1(config-router)#version 2

R1(config-router)#network 192.168.2.0

R1(config-router)#network 172.16.40.0

עכשיו נעבור ל R7 על מנת להגדיר את הרשתות שהוא מכיר ומחוברות אליו

R7>en

R7#conf t

R7(config)#router rip

R7(config-router)#version 2

R7(config-router)#network 192.168.3.0

R7(config-router)#network 172.16.50.0

עכשיו נעבור ל R8 על מנת להגדיר את הרשתות שהוא מכיר ומחוברות אליו

R8>en

R8#conf t

R8(config)#router rip

R8(config-router)#version 2

R8(config-router)#network 192.168.4.0

R8(config-router)#network 172.16.60.0

עכשיו נעבור ל R10 על מנת להגדיר את הרשתות שהוא מכיר ומחוברות אליו

R10>en

R10#conf t

R10(config)#router rip

R10(config-router)#version 2

R10(config-router)#network 172.16.30.0

R10(config-router)#network 172.16.40.0

R10(config-router)#network 172.16.70.0

R10(config-router)#network 172.16.10.0

עכשיו נעבור ל R9 על מנת להגדיר את הרשתות שהוא מכיר ומחוברות אליו

R9>en

R9#conf t

R9(config)#router rip

R9(config-router)#version 2

R9(config-router)#network 172.16.70.0

R9(config-router)#network 172.16.20.0

R9(config-router)#network 172.16.60.0

R9(config-router)#network 172.16.50.0

עכשיו נעבור ל R11 על מנת להגדיר את הרשתות שהוא מכיר ומחוברות אליו

R11>en

R11#conf t

R11(config)#router rip

R1(config-router)#version 2

R11(config-router)#network 172.16.10.0

R11(config-router)#network 172.16.20.0

כעת בדקו את טבלת הניתוב למשל של Router10

R10#show ip route

Codes: C – connected, S – static, I – IGRP, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2, E – EGP

i – IS-IS, L1 – IS-IS level-1, L2 – IS-IS level-2, ia – IS-IS inter area

* – candidate default, U – per-user static route, o – ODR

P – periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/32 is subnetted, 1 subnets

C 10.10.10.10 is directly connected, Loopback0

172.16.0.0/24 is subnetted, 7 subnets

C 172.16.10.0 is directly connected, GigabitEthernet0/0

R 172.16.20.0 [120/1] via 172.16.70.2, 00:00:15, GigabitEthernet1/0

[120/1] via 172.16.10.2, 00:00:21, GigabitEthernet0/0

C 172.16.30.0 is directly connected, GigabitEthernet2/0

C 172.16.40.0 is directly connected, GigabitEthernet3/0

R 172.16.50.0 [120/1] via 172.16.70.2, 00:00:15, GigabitEthernet1/0

R 172.16.60.0 [120/1] via 172.16.70.2, 00:00:15, GigabitEthernet1/0

C 172.16.70.0 is directly connected, GigabitEthernet1/0

R 192.168.1.0/24 [120/1] via 172.16.30.1, 00:00:06, GigabitEthernet2/0

R 192.168.2.0/24 [120/1] via 172.16.40.1, 00:00:11, GigabitEthernet3/0

R 192.168.3.0/24 [120/2] via 172.16.70.2, 00:00:15, GigabitEthernet1/0

R 192.168.4.0/24 [120/2] via 172.16.70.2, 00:00:15, GigabitEthernet1/0

ניתן לראות באדום את הניתובים שהוא למד דרך RIP, ה AD שרשום 120 ואת כמות ה HOP הקפיצות על מנת להגיע ליעד! [120/2]

ניתן לראות באיזה פרוטוקול הראוטר משתמש על ידי הפקודה

R10#show ip protocols

Routing Protocol is “rip

Sending updates every 30 seconds, next due in 7 seconds

Invalid after 180 seconds, hold down 180, flushed after 240

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

Redistributing: rip

Default version control: send version 2, receive 2

Interface Send Recv Triggered RIP Key-chain

GigabitEthernet0/0 2 2

GigabitEthernet1/0 2 2

GigabitEthernet2/0 2 2

GigabitEthernet3/0 2 2

Automatic network summarization is in effect

Maximum path: 4

Routing for Networks:

172.16.0.0

Passive Interface(s):

Routing Information Sources:

Gateway Distance Last Update

172.16.70.2 120 00:00:16

172.16.10.2 120 00:00:25

172.16.30.1 120 00:00:01

172.16.40.1 120 00:00:22

Distance: (default is 120)

באדום מסומן לכם פרוטוקול הניתוב, איזה Interfaces הם חלק מהניתוב, והכי חשוב שהוא ביצע Summary לרשת (ניתן לקרוא באתר בהרחבה על Summary).

 

כל הזכויות שמורות לטל בן שושן – Shushan.co.il

להורדת המעבדה (מוכנה)

image_pdfלהורדת המסמך כPDF לחצו כאןimage_printלהדפסת המסמך לחצו כאן

מאמרים קשורים

Leave a Comment